Your browser either does not support JavaScript or you have turned JavaScript off.

Zyxel security advisory for buffer overflow vulnerabilities of GS1900 switches

Summary

Zyxel’s GS1900 series switches are susceptible to buffer overflow vulnerabilities that could possibly allow device takeover without requiring credentials. Users are urged to upgrade immediately to the latest available firmware for optimal protection.


What's the vulnerability?

Multiple buffer overflow vulnerabilities were identified in the embedded web server of the affected devices due to several improper uses of the “strcpy()” function when processing web requests. The web server returns the HTTP ETag header with a specific value that could allow remote fingerprinting of the device.


What should you do?

After a thorough investigation, we’ve identified the affected products and released firmware that addresses the vulnerabilities. We urge users to check the table below and install the latest firmware immediately.


Device impacted Latest firmware version
GS1900-8 2.40(AAHH.2)C0
GS1900-8HP 2.40(AAHI.2)C0
GS1900-10HP 2.40(AAZI.2)C0
GS1900-16 2.40(AAHJ.2)C0
GS1900-24E 2.40(AAHK.2)C0
GS1900-24 2.40(AAHL.2)C0
GS1900-24HP 2.40(AAHM.2)C0
GS1900-48 2.40(AAHN.2)C0
GS1900-48HP 2.40(AAHO.2)C0

Got a question or a tipoff?

Please contact your local service rep for further information or assistance. If you’ve found a vulnerability, we want to work with you to fix it—contact security@zyxel.com.tw and we’ll get right back to you.


Acknowledgement

Thanks to Bashis for reporting this vulnerability to us.


Revision history

2018-08-06: Initial release