Your browser either does not support JavaScript or you have turned JavaScript off. ZyXEL to Release Patch for KCodes NetUSB Vulnerability | ZyXEL

ZyXEL to Release Patch for KCodes NetUSB Vulnerability

ZyXEL to Release Patch for KCodes NetUSB Vulnerability

A new vulnerability in KCodes NetUSB kernel driver, identified in advisory CVE-2015-3036, exposes a stack-based buffer overflow weakness that could result in a denial of service or arbitrary code execution.

ZyXEL is aware of the vulnerability to KCodes NetUSB on four of ZyXEL routers and assures our customers that the rest of ZyXEL products are not affected. ZyXEL has identified the root cause and a fix to the problem. We are now in the process of rebuilding the NetUSB modules on the affected routers, and the updated release will be available as stated in the table below.

Affected models

ProductModel NameFirmware Update
Wireless N300 NetUSB Router NBG-419N v2 2015/06/18
Wireless N300 Gigabit NetUSB Router NBG4615 v2 2015/06/18
Simultaneous Dual-Band Wireless N750 Media Router NBG5615 2015/06/18
Simultaneous Dual-Band Wireless N900 Media Router NBG5715 2015/06/18
Please contact your local service or sales representative for further assistance.
US / EN